Categories

Archives

A sample text widget

Etiam pulvinar consectetur dolor sed malesuada. Ut convallis euismod dolor nec pretium. Nunc ut tristique massa.

Nam sodales mi vitae dolor ullamcorper et vulputate enim accumsan. Morbi orci magna, tincidunt vitae molestie nec, molestie at mi. Nulla nulla lorem, suscipit in posuere in, interdum non magna.

USA: Nissan Dealer Warns Customers: Using GE’s WattStation Charger Can Damage Your LEAF

General Electric’s WattStation Level 2 Charging Station has been blamed for breaking the onboard charging systems in multiple Nissan LEAFs.
A Bay Area Nissan dealership sent an urgent email yesterday evening warning customers to avoid using General Electric’s WattStation to charge their LEAFs due to the possibility that the Level 2 home charge station could do damage to the car’s onboard charger. The message from Hanlee Hiltop Nissan of San Pablo, Calif., stated that Nissan has identified multiple documented cases of cars losing their ability to charge after being connected to the WattStation. A representative of Hanlee Hilltop Nissan confirmed to PluginCars.com that Nissan North America’s regional operations manager sent an email to dealers yesterday alerting them to the problem.

A quick search of the MyNissanLeaf Forum reveals that reports of the issue may date back at least as far as April of this year, and that local dealerships have been forced to replace the onboard chargers in several vehicles across multiple states. Here’s an excerpt of one of those accounts:

We’ve had our Leaf since May 19th but only driven it about 350 miles so far… charged it with our GE Wattstation maybe 6 or 7 times. Plugged it in to charge last Thursday, the charger came on, the charging lights on the car started blinking and then everything went off. Tried multiple times. Took it to a nearby Nissan dealer to plug into their charger. Nothing. Tried the trickle charger at home. Nothing. The Nissan Dealer we got it from came to our house Friday to run diagnostics which said the on-board charger was bad and he told us they knew of problems with the GE chargers causing this.
More plugincarfs.com

Share

Leave a Reply